re = /^alp:[^:]+:([^:]+).*$/m
str = 'mfast_acquired_theresasale
alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion
alp:psch_nb:paid keyword:rewardsclub
alp:psch_nb:gifts:sale
alp:psch_things:keyword_phrase '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end