import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^alp:[^:]+:([^:]+).*$";
final String string = "mfast_acquired_theresasale\n"
+ "alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion\n"
+ "alp:psch_nb:paid keyword:rewardsclub\n"
+ "alp:psch_nb:gifts:sale\n"
+ "alp:psch_things:keyword_phrase ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}