// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^alp:[^:]+:([^:]+).*$").unwrap();
let string = "mfast_acquired_theresasale
alp:psch_nb_b2b:thisisthekeyword:thisistheoccassion
alp:psch_nb:paid keyword:rewardsclub
alp:psch_nb:gifts:sale
alp:psch_things:keyword_phrase ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}