using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(.*(?<!friends)(?<!friends\/))\?.*$";
string substitution = @"$1";
string input = @"/friends?guest=1&event=chill_out&submit=2
/friends/?more_params
/friend/?more_params
/friend?more_params";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}