const regex = /\/(.*(?<!friends)(?<!friends\/))\?.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(.*(?<!friends)(?<!friends\\\/))\\?.*$', 'gm')
const str = `/friends?guest=1&event=chill_out&submit=2
/friends/?more_params
/friend/?more_params
/friend?more_params`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);