re = /\/(.*(?<!friends)(?<!friends\/))\?.*$/m
str = '/friends?guest=1&event=chill_out&submit=2
/friends/?more_params
/friend/?more_params
/friend?more_params'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result