import re
regex = re.compile(r"\/(.*(?<!friends)(?<!friends\/))\?.*$", flags=re.MULTILINE)
test_str = ("/friends?guest=1&event=chill_out&submit=2\n"
"/friends/?more_params\n"
"/friend/?more_params\n"
"/friend?more_params")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)