$re = '/\/(.*(?<!friends)(?<!friends\/))\?.*$/m';
$str = '/friends?guest=1&event=chill_out&submit=2
/friends/?more_params
/friend/?more_params
/friend?more_params';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;