using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(?:
(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)
(?:
,(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)*
$";
string input = @"10,20-30,35-40
70-50
50
500
40-50,50-60,5,50
40-50,6555
5-50
5,80
8,71
test and lol
08,60
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}