// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?:
(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)
(?:
,(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)*
$").unwrap();
let string = "10,20-30,35-40
70-50
50
500
40-50,50-60,5,50
40-50,6555
5-50
5,80
8,71
test and lol
08,60
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}