re = /^
(?:
(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)
(?:
,(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)*
$/mx
str = '10,20-30,35-40
70-50
50
500
40-50,50-60,5,50
40-50,6555
5-50
5,80
8,71
test and lol
08,60
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end