import re
regex = re.compile(r"""
^
(?:
(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)
(?:
,(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)*
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("10,20-30,35-40\n"
"70-50\n"
"50\n"
"500\n"
"40-50,50-60,5,50\n"
"40-50,6555\n"
"5-50\n"
"5,80\n"
"8,71\n"
"test and lol\n"
"08,60\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")