const regex = /^
(?:
(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)
(?:
,(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)*
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?:
(?:[0-6]?\\d|70)(?:-[0-6]?\\d|70)?
)
(?:
,(?:[0-6]?\\d|70)(?:-[0-6]?\\d|70)?
)*
$', 'gm')
const str = `10,20-30,35-40
70-50
50
500
40-50,50-60,5,50
40-50,6555
5-50
5,80
8,71
test and lol
08,60
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}