use strict;
my $str = '10,20-30,35-40
70-50
50
500
40-50,50-60,5,50
40-50,6555
5-50
5,80
8,71
test and lol
08,60
';
my $regex = qr/^
(?:
(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)
(?:
,(?:[0-6]?\d|70)(?:-[0-6]?\d|70)?
)*
$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}