# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w+)$/$1/gm;t' <<< "MONKS, Timothy Peter, Dr
Dr Timothy Peter Monks"