using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)$";
string substitution = @"$1";
string input = @"MONKS, Timothy Peter, Dr
Dr Timothy Peter Monks";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}