$re = '/\b(\w+)$/m';
$str = 'MONKS, Timothy Peter, Dr
Dr Timothy Peter Monks';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;