use strict;
my $str = 'MONKS, Timothy Peter, Dr
Dr Timothy Peter Monks';
my $regex = qr/\b(\w+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";