const regex = /\b(\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)$', 'gm')
const str = `MONKS, Timothy Peter, Dr
Dr Timothy Peter Monks`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);