import re
regex = re.compile(r"\b(\w+)$", flags=re.MULTILINE)
test_str = ("MONKS, Timothy Peter, Dr\n"
"Dr Timothy Peter Monks")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)