package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\w+)$`)
var str = `MONKS, Timothy Peter, Dr
Dr Timothy Peter Monks`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}