# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([.,:;!)|\]])\s*([a-zA-Z]+)//gm;t' <<< "This is text.Another text.Next case"