using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([.,:;!)|\]])\s*([a-zA-Z]+)";
string substitution = @"";
string input = @"This is text.Another text.Next case";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}