$re = '/([.,:;!)|\]])\s*([a-zA-Z]+)/m';
$str = 'This is text.Another text.Next case';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;