use strict;
my $str = 'This is text.Another text.Next case';
my $regex = qr/([.,:;!)|\]])\s*([a-zA-Z]+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";