const regex = new RegExp('([.,:;!)|\\]])\\s*([a-zA-Z]+)', 'gm')
const str = `This is text.Another text.Next case`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);