package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([.,:;!)|\]])\s*([a-zA-Z]+)`)
var str = `This is text.Another text.Next case`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}