re = /([.,:;!)|\]])\s*([a-zA-Z]+)/m
str = 'This is text.Another text.Next case'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result