#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\b"
Local $sString = "yest" & @CRLF & _
"yeste" & @CRLF & _
"yester" & @CRLF & _
"yesterd" & @CRLF & _
"yesterda" & @CRLF & _
"yesterday" & @CRLF & _
"tod" & @CRLF & _
"toda" & @CRLF & _
"today" & @CRLF & _
"tom" & @CRLF & _
"tomo" & @CRLF & _
"tomor" & @CRLF & _
"tomorr" & @CRLF & _
"tomorro" & @CRLF & _
"tomorrow" & @CRLF & _
"" & @CRLF & _
"yesteray" & @CRLF & _
"tomorow" & @CRLF & _
"tommorrow" & @CRLF & _
"tody" & @CRLF & _
"yesteday"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")