// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\b").unwrap();
let string = "yest
yeste
yester
yesterd
yesterda
yesterday
tod
toda
today
tom
tomo
tomor
tomorr
tomorro
tomorrow
yesteray
tomorow
tommorrow
tody
yesteday";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}