import re
regex = re.compile(r"\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\b", flags=re.IGNORECASE)
test_str = ("yest\n"
"yeste\n"
"yester\n"
"yesterd\n"
"yesterda\n"
"yesterday\n"
"tod\n"
"toda\n"
"today\n"
"tom\n"
"tomo\n"
"tomor\n"
"tomorr\n"
"tomorro\n"
"tomorrow\n\n"
"yesteray\n"
"tomorow\n"
"tommorrow\n"
"tody\n"
"yesteday")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")