re = /\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\b/i
str = 'yest
yeste
yester
yesterd
yesterda
yesterday
tod
toda
today
tom
tomo
tomor
tomorr
tomorro
tomorrow
yesteray
tomorow
tommorrow
tody
yesteday'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end