import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\\b";
final String string = "yest\n"
+ "yeste\n"
+ "yester\n"
+ "yesterd\n"
+ "yesterda\n"
+ "yesterday\n"
+ "tod\n"
+ "toda\n"
+ "today\n"
+ "tom\n"
+ "tomo\n"
+ "tomor\n"
+ "tomorr\n"
+ "tomorro\n"
+ "tomorrow\n\n"
+ "yesteray\n"
+ "tomorow\n"
+ "tommorrow\n"
+ "tody\n"
+ "yesteday";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}