package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(yest(?:e(?:r(?:d(?:ay?)?)?)?)?|tod(?:ay?)?|tom(?:o(?:r(?:r(?:ow?)?)?)?)?)\b`)
var str = `yest
yeste
yester
yesterd
yesterda
yesterday
tod
toda
today
tom
tomo
tomor
tomorr
tomorro
tomorrow
yesteray
tomorow
tommorrow
tody
yesteday`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}