using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p><img.+class=\"")(classIWantToMatch)(\"".+<\/p>)";
string input = @"<p><img class=""classIWantToMatch"" src=""data:image/gif;base64,dataForImage""></p>
<p><img src=""data:image/gif;base64,imageData"" class=""classIWantToMatch"" ></p>
<p><img src=""/myFiles/my.PNG"" alt=""></p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}