// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<p><img.+class=\")(classIWantToMatch)(\".+<\/p>)"#).unwrap();
let string = "<p><img class=\"classIWantToMatch\" src=\"data:image/gif;base64,dataForImage\"></p>
<p><img src=\"data:image/gif;base64,imageData\" class=\"classIWantToMatch\" ></p>
<p><img src=\"/myFiles/my.PNG\" alt=\"\"></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}