re = /(<p><img.+class=\")(classIWantToMatch)(\".+<\/p>)/m
str = '<p><img class="classIWantToMatch" src="data:image/gif;base64,dataForImage"></p>
<p><img src="data:image/gif;base64,imageData" class="classIWantToMatch" ></p>
<p><img src="/myFiles/my.PNG" alt=""></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end