const regex = /(<p><img.+class=\")(classIWantToMatch)(\".+<\/p>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p><img.+class=\\")(classIWantToMatch)(\\".+<\\\/p>)', 'gm')
const str = `<p><img class="classIWantToMatch" src="data:image/gif;base64,dataForImage"></p>
<p><img src="data:image/gif;base64,imageData" class="classIWantToMatch" ></p>
<p><img src="/myFiles/my.PNG" alt=""></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}