$re = '/(<p><img.+class=\")(classIWantToMatch)(\".+<\/p>)/m';
$str = '<p><img class="classIWantToMatch" src="data:image/gif;base64,dataForImage"></p>
<p><img src="data:image/gif;base64,imageData" class="classIWantToMatch" ></p>
<p><img src="/myFiles/my.PNG" alt=""></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);