import re
regex = re.compile(r"(<p><img.+class=\")(classIWantToMatch)(\".+<\/p>)", flags=re.MULTILINE)
test_str = ("<p><img class=\"classIWantToMatch\" src=\"data:image/gif;base64,dataForImage\"></p>\n"
"<p><img src=\"data:image/gif;base64,imageData\" class=\"classIWantToMatch\" ></p>\n"
"<p><img src=\"/myFiles/my.PNG\" alt=\"\"></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")