# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)@?([^\s@]+)@[^\s@]+(?!\S)/$1/gm;t' <<< "firstname.lastname@domain.co.uk
firstname.middlename.lastname@domain.co.uk
@firstname.lastname@domain.co.uk
The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence.
The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence."