use strict;
my $str = 'firstname.lastname@domain.co.uk
firstname.middlename.lastname@domain.co.uk
@firstname.lastname@domain.co.uk
The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence.
The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence.';
my $regex = qr/(?<!\S)@?([^\s@]+)@[^\s@]+(?!\S)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";