import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)@?([^\\s@]+)@[^\\s@]+(?!\\S)";
final String string = "firstname.lastname@domain.co.uk\n"
+ "firstname.middlename.lastname@domain.co.uk\n"
+ "@firstname.lastname@domain.co.uk\n"
+ "The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence.\n\n"
+ "The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}