#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)@?([^\s@]+)@[^\s@]+(?!\S)"
Local $sString = "firstname.lastname@domain.co.uk" & @CRLF & _
"firstname.middlename.lastname@domain.co.uk" & @CRLF & _
"@firstname.lastname@domain.co.uk" & @CRLF & _
"The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence." & @CRLF & _
"" & @CRLF & _
"The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)