# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)@?([^\s@]+)@[^\s@]+(?!\S)"
test_str = ("firstname.lastname@domain.co.uk\n"
"firstname.middlename.lastname@domain.co.uk\n"
"@firstname.lastname@domain.co.uk\n"
"The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence.\n\n"
"The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence.")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.