$re = '/(?<!\S)@?([^\s@]+)@[^\s@]+(?!\S)/m';
$str = 'firstname.lastname@domain.co.uk
firstname.middlename.lastname@domain.co.uk
@firstname.lastname@domain.co.uk
The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence.
The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;