import Foundation
let pattern = #"(?<!\S)@?([^\s@]+)@[^\s@]+(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
firstname.lastname@domain.co.uk
firstname.middlename.lastname@domain.co.uk
@firstname.lastname@domain.co.uk
The cat sat on the mat whilst @firstname.lastname@domain.co.uk watched in silence.
The cat sat on the mat whilst @firstname.@lastname@domain.co.uk watched in silence.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)