#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)R?[CD]\d+(?:[,.]\d+)?"
Local $sString = "8372C8932,25adfadf" & @CRLF & _
"82912RC839,00klsd" & @CRLF & _
"87D74,23lsdf" & @CRLF & _
"97571RD876,55adsf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")