const regex = /R?[CD]\d+(?:[,.]\d+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('R?[CD]\\d+(?:[,.]\\d+)?', 'gm')
const str = `8372C8932,25adfadf
82912RC839,00klsd
87D74,23lsdf
97571RD876,55adsf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}