using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"R?[CD]\d+(?:[,.]\d+)?";
string input = @"8372C8932,25adfadf
82912RC839,00klsd
87D74,23lsdf
97571RD876,55adsf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}